summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 13:18:54 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit85b2a2f541013d841e05eb12c74285086bae172d (patch)
tree1e539bb67b4a4ec6983f1a647c0397be55a7ffc0
parent6397aef061e48e87f036fcee81cbe59349b04247 (diff)
gnu: Add ghc-resourcet.
* gnu/packages/haskell.scm (ghc-resourcet): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6d479d208b..3e6db05be1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -523,6 +523,37 @@ hopefully make them easier to read. HLint also makes it easy to disable
unwanted suggestions, and to add your own custom suggestions.")
(license bsd-3)))
+(define-public ghc-resourcet
+ (package
+ (name "ghc-resourcet")
+ (version "1.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/resourcet/resourcet-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0zhsaaa4n8ry76vjih519a8npm2hrzk10d5asrgllcwpzmifl41y"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-mmorph" ,ghc-mmorph)
+ ("ghc-exceptions" ,ghc-exceptions)))
+ (inputs
+ `(("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "http://github.com/snoyberg/conduit")
+ (synopsis "Deterministic allocation and freeing of scarce resources")
+ (description "ResourceT is a monad transformer which creates a region of
+code where you can safely allocate resources.")
+ (license bsd-3)))
+
(define-public cpphs
(package
(name "cpphs")