summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 18:05:08 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit894562e3141abb68d877ea4f75b8a80c764cda03 (patch)
treede48d29a245a5e2966de8c158aac11abbc98bd2a
parentc480b85e662cabb8a111873e193ebf27bcac17a0 (diff)
gnu: Add ghc-gluraw.
* gnu/packages/haskell.scm (ghc-gluraw): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 49ce141e2f..e561f4d2ad 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -879,6 +879,30 @@ C header files are needed for building this package. If an API entry is not
found at runtime, a userError is thrown.")
(license bsd-3)))
+(define-public ghc-gluraw
+ (package
+ (name "ghc-gluraw")
+ (version "1.5.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/GLURaw/GLURaw-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0gscd9lhp9mb10q8s716nx26m8qng9xbb4h6b3f48zzgkc1sy96x"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-openglraw" ,ghc-openglraw)))
+ (home-page "http://www.haskell.org/haskellwiki/Opengl")
+ (synopsis "Raw Haskell bindings GLU")
+ (description "GLURaw is a raw Haskell binding for the GLU 1.3 OpenGL
+utility library. It is basically a 1:1 mapping of GLU's C API, intended as a
+basis for a nicer interface.")
+ (license bsd-3)))
+
(define-public ghc-streaming-commons
(package
(name "ghc-streaming-commons")