summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 15:00:06 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitaa6f39127e7d4bd5783b4454f5b6b7cd243aa8b8 (patch)
tree73a97a3fbff0148c675225069457e23df2d698f6
parentc783cac07006a18c4c67f7c0b77f2f94ebcff287 (diff)
gnu: Add Raincat.
* gnu/packages/games.scm (raincat): New variable.
-rw-r--r--gnu/packages/games.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9c44bbe3e0..546944ad25 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libunwind)
+ #:use-module (gnu packages haskell)
#:use-module (gnu packages mp3)
#:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
@@ -81,6 +82,7 @@
#:use-module (gnu packages fribidi)
#:use-module (guix build-system trivial)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system haskell)
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial))
@@ -1139,6 +1141,39 @@ on the screen and keyboard to display letters.")
;; Most files under gpl2+ or gpl3+, but eat.wav under gpl3
(license license:gpl3)))
+(define-public raincat
+ (package
+ (name "raincat")
+ (version "1.1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/Raincat/Raincat-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1aalh68h6799mv4vyg30zpskl5jkn6x2j1jza7p4lrflyifxzar8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-random" ,ghc-random)
+ ("ghc-glut" ,ghc-glut)
+ ("ghc-opengl" ,ghc-opengl)
+ ("ghc-sdl" ,ghc-sdl)
+ ("ghc-sdl-image" ,ghc-sdl-image)
+ ("ghc-sdl-mixer" ,ghc-sdl-mixer)))
+ (home-page "http://raincat.bysusanlin.com/")
+ (synopsis "Puzzle game with a cat in lead role")
+ (description "Project Raincat is a game developed by Carnegie Mellon
+students through GCS during the Fall 2008 semester. Raincat features game
+play inspired from classics Lemmings and The Incredible Machine. The project
+proved to be an excellent learning experience for the programmers. Everything
+is programmed in Haskell.")
+ (license license:bsd-3)))
+
(define-public manaplus
(package
(name "manaplus")