summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:19:41 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitb53fa04681cc9250837f104a34386d5521d7221b (patch)
treeb1b5a14a4816822be57f39bc6334e8d4d053d9da
parent9855500af6b4516da998fb51ee3c20f3677fa466 (diff)
gnu: Add ghc-smallcheck.
* gnu/packages/haskell.scm (ghc-smallcheck): New variable.
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6da0c1d1e3..566f11ec4a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1351,6 +1351,33 @@ use them without linking against Cabal or depending on it being installed.
This is a better maintained fork of the \"temporary\" package.")
(license bsd-3)))
+(define-public ghc-smallcheck
+ (package
+ (name "ghc-smallcheck")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/smallcheck/smallcheck-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1ygrabxh40bym3grnzqyfqn96lirnxspb8cmwkkr213239y605sd"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-logict" ,ghc-logict)))
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)))
+ (home-page
+ "https://github.com/feuerbach/smallcheck")
+ (synopsis "Property-based testing library")
+ (description "SmallCheck is a testing library that allows to verify
+properties for all test cases up to some depth. The test cases are generated
+automatically by SmallCheck.")
+ (license bsd-3)))
+
(define-public ghc-silently
(package
(name "ghc-silently")