summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 11:51:46 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitbce030840d597df195630a6883841c917da4ec75 (patch)
tree24af7077667ce70de1d7b2951d57f7a72130186b
parentfe28ba703f1d72b15428d9c214251d6fd9bf3b5c (diff)
gnu: Add ghc-glut.
* gnu/packages/haskell.scm (ghc-glut): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9c55153ad8..1d0dd1aea1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -902,6 +902,34 @@ C header files are needed for building this package. If an API entry is not
found at runtime, a userError is thrown.")
(license bsd-3)))
+(define-public ghc-glut
+ (package
+ (name "ghc-glut")
+ (version "2.7.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/GLUT/GLUT-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qfilpc10jm47anan44c20y8mh76f2dv09m5d22gk0f7am7hg4k2"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-statevar" ,ghc-statevar)
+ ("ghc-openglraw" ,ghc-openglraw)))
+ (inputs
+ `(("ghc-opengl" ,ghc-opengl)
+ ("freeglut" ,freeglut)))
+ (home-page "http://www.haskell.org/haskellwiki/Opengl")
+ (synopsis "Haskell bindings for the OpenGL Utility Toolkit")
+ (description "This library provides Haskell bindings for the OpenGL
+Utility Toolkit, a window system-independent toolkit for writing OpenGL
+programs.")
+ (license bsd-3)))
+
(define-public ghc-gluraw
(package
(name "ghc-gluraw")