summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 11:36:58 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitc480b85e662cabb8a111873e193ebf27bcac17a0 (patch)
tree9b2ad60e8ce38bb6cc1f6d0c00c2abdac377ac86
parent22db3ce71a85d8cfc697f5fdca3ec353ee80db52 (diff)
gnu: Add ghc-openglraw.
* gnu/packages/haskell.scm (ghc-openglraw): New variable.
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 05031f240e..49ce141e2f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages compression)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages zip)
#:use-module (gnu packages gcc)
@@ -846,6 +847,38 @@ attacks.")
computation library for Haskell.")
(license bsd-3)))
+(define-public ghc-openglraw
+ (package
+ (name "ghc-openglraw")
+ (version "2.5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/OpenGLRaw/OpenGLRaw-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1kfq24mxg922ml3kkmym2qfpc56jbmrfbiix4rc2cxlwv05i191k"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-half" ,ghc-half)
+ ("glu" ,glu)
+ ("ghc-text" ,ghc-text)))
+ (home-page "http://www.haskell.org/haskellwiki/Opengl")
+ (synopsis "Raw Haskell bindings for the OpenGL graphics system")
+ (description "OpenGLRaw is a raw Haskell binding for the OpenGL 4.5
+graphics system and lots of OpenGL extensions. It is basically a 1:1 mapping
+of OpenGL's C API, intended as a basis for a nicer interface. OpenGLRaw
+offers access to all necessary functions, tokens and types plus a general
+facility for loading extension entries. The module hierarchy closely mirrors
+the naming structure of the OpenGL extensions, making it easy to find the
+right module to import. All API entries are loaded dynamically, so no special
+C header files are needed for building this package. If an API entry is not
+found at runtime, a userError is thrown.")
+ (license bsd-3)))
+
(define-public ghc-streaming-commons
(package
(name "ghc-streaming-commons")