summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:43:48 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitd2639cbc1781fd39bc80d1dddad61fb85c871174 (patch)
tree2f20fb2b31af62fda74cc38fdba156508b8caf41
parentaee98223264974637987a7fca2c701c0954ffd79 (diff)
gnu: Add ghc-reducers.
* gnu/packages/haskell.scm (ghc-reducers): New variable.
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 12c5a93f60..3a3522a749 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1400,6 +1400,35 @@ this package makes them available back to GHC 7.2.")
(description "This library provides profunctors for Haskell.")
(license bsd-3)))
+(define-public ghc-reducers
+ (package
+ (name "ghc-reducers")
+ (version "3.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/reducers/reducers-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0pkddg0s3cn759miq0nfrq7lnp3imk5sx784ihsilsbjh9kvffz4"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-semigroupoids" ,ghc-semigroupoids)))
+ (inputs
+ `(("ghc-fingertree" ,ghc-fingertree)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (home-page "http://github.com/ekmett/reducers/")
+ (synopsis "Semigroups, specialized containers and a general map/reduce framework")
+ (description "This library provides various semigroups, specialized
+containers and a general map/reduce framework for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")