summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 16:41:58 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitd6a08d24bfd4eb94d761b23d2f57810100f7abb3 (patch)
tree80994559c534924aa326b69c9f54aa899de4e86b
parentf550db48ebea7d0ce494641ebaf7d33ccd3f40ec (diff)
gnu: Add ghc-xss-sanitize.
* gnu/packages/haskell.scm (ghc-xss-sanitize): New variable.
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09ab4aa349..19fc409943 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -554,6 +554,38 @@ unwanted suggestions, and to add your own custom suggestions.")
code where you can safely allocate resources.")
(license bsd-3)))
+(define-public ghc-xss-sanitize
+ (package
+ (name "ghc-xss-sanitize")
+ (version "0.3.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/xss-sanitize/xss-sanitize-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1j2qrn2dbfx01m7zyk9ilgnp9zjwq9mk62b0rdal4zkg4vh212h0"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-tagsoup" ,ghc-tagsoup)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-css-text" ,ghc-css-text)
+ ("ghc-network-uri" ,ghc-network-uri)))
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://github.com/yesodweb/haskell-xss-sanitize")
+ (synopsis "Sanitize untrusted HTML to prevent XSS attacks")
+ (description "This library provides @code{sanitizeXSS}. Run untrusted
+HTML through @code{Text.HTML.SanitizeXSS.sanitizeXSS} to prevent XSS
+attacks.")
+ (license bsd-3)))
+
(define-public ghc-streaming-commons
(package
(name "ghc-streaming-commons")