summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 11:13:03 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commite0d17b848226ef9401b1d588896942a96b1fdbd4 (patch)
treee22c25ccb25a5147ab3f2b709f376f7d48924181
parent0bc641baf86b651a059fc53358d220a08dc7123c (diff)
gnu: Add ghc-haskell-src.
* gnu/packages/haskell.scm (ghc-haskell-src): New variable.
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1928793536..b8875ae0b1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -541,6 +541,35 @@ them.")
documents.")
(license bsd-3)))
+(define-public ghc-haskell-src
+ (package
+ (name "ghc-haskell-src")
+ (version "1.0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/haskell-src/haskell-src-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "19lilhpwnjb7cks9fq1ipnc8f7dwxy0ri3dgjkdxs3i355byw99a"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-happy" ,ghc-happy)
+ ("ghc-syb" ,ghc-syb)))
+ (home-page
+ "http://hackage.haskell.org/package/haskell-src")
+ (synopsis
+ "Support for manipulating Haskell source code")
+ (description
+ "The 'haskell-src' package provides support for manipulating Haskell
+source code. The package provides a lexer, parser and pretty-printer, and a
+definition of a Haskell abstract syntax tree (AST). Common uses of this
+package are to parse or generate Haskell 98 code.")
+ (license bsd-3)))
+
(define-public ghc-alex
(package
(name "ghc-alex")