summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 16:43:40 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commite372520ec3a6b6a091d12a82291d505c1bb9b5bd (patch)
tree65f3939c74c5f5eae49251e7c196f2bf80a65c5b
parentd6a08d24bfd4eb94d761b23d2f57810100f7abb3 (diff)
gnu: Add ghc-parsers.
* gnu/packages/haskell.scm (ghc-parsers): New variable.
-rw-r--r--gnu/packages/haskell.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 19fc409943..1aa39ea62d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1443,6 +1443,41 @@ regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
@code{libtre} (fork by Roman Cheplyaka).")
(license bsd-3)))
+(define-public ghc-parsers
+ (package
+ (name "ghc-parsers")
+ (version "0.12.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/parsers/parsers-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "18wzmp8y3py4qa8hdsxqm0jfzmwy744dw7xa48r5s8ynhpimi462"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: Test fails with "cannot satisfy
+ ; -package attoparsec-0.13.0.1"
+ (propagated-inputs
+ `(("ghc-base-orphans" ,ghc-base-orphans)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-charset" ,ghc-charset)))
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (home-page "http://github.com/ekmett/parsers/")
+ (synopsis "Parsing combinators")
+ (description "This library provides convenient combinators for working
+with and building parsing combinator libraries. Given a few simple instances,
+you get access to a large number of canned definitions. Instances exist for
+the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
+@code{Text.Read}.")
+ (license bsd-3)))
+
(define-public ghc-attoparsec
(package
(name "ghc-attoparsec")