summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:39:20 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitfad564ec035a3e0b99c3e28704070fb751480852 (patch)
treedb1a30ca49db4a849b7fa1b1154c47da2b0a9c74
parent47038762bac1b2f0144b49636d9eb0263aec8d12 (diff)
gnu: Add ghc-extra.
* gnu/packages/haskell.scm (ghc-extra): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dd525bca30..eeff0d8c74 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1351,6 +1351,30 @@ standard Read class, for better deserialisation of Haskell values from
Strings.")
(license lgpl2.1)))
+(define-public ghc-extra
+ (package
+ (name "ghc-extra")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/extra/extra-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1h9hxkrqrqscx420yz1lmivbrhi6jc3a5ap61vkxd2mhdgark9hf"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/ndmitchell/extra")
+ (synopsis "Extra Haskell functions")
+ (description "This library provides extra functions for the standard
+Haskell libraries. Most functions are simple additions, filling out missing
+functionality. A few functions are available in later versions of GHC, but
+this package makes them available back to GHC 7.2.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")