summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolay Korotkiy <sikmir@gmail.com>2021-12-15 16:09:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-15 16:10:16 +0100
commit02c9a0697632847e9ad83f6ba42b12eef29bb0df (patch)
tree93768cf8988cef1cb2b86aca480098e2d704fa87
parent94becb63591bd928d323067b1b81f2c1f293d77e (diff)
gnu: Add openorienteering-mapper.
* gnu/packages/geo.scm (openorienteering-mapper): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/geo.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5fb0f633a3..02db04e38c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,8 @@
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
+ #:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
@@ -2041,6 +2044,46 @@ track your position right from your laptop.")
license:sgifreeb2.0
license:zlib))))
+(define-public openorienteering-mapper
+ (package
+ (name "openorienteering-mapper")
+ (version "0.9.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenOrienteering/mapper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11b578h8f3q9yvphbjhqmy2w1cfc9skslzawypqmc3k44v24aj0s"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list
+ "-DLICENSING_PROVIDER:BOOL=OFF"
+ "-DMapper_MANUAL_QTHELP:BOOL=OFF")))
+ (inputs
+ `(("clipper" ,clipper)
+ ("cups" ,cups)
+ ("gdal" ,gdal)
+ ("proj" ,proj)
+ ("qtbase" ,qtbase-5)
+ ("qtimageformats" ,qtimageformats)
+ ("qtlocation" ,qtlocation)
+ ("qtsensors" ,qtsensors)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("qttools" ,qttools)))
+ (home-page "https://www.openorienteering.org/apps/mapper/")
+ (synopsis "OpenOrienteering Mapper (OOM)")
+ (description
+ "OpenOrienteering Mapper is a software for creating maps for the
+orienteering sport.")
+ (license license:gpl3+)))
+
(define-public grass
(let* ((version "7.8.5")
(majorminor (string-join (list-head (string-split version #\.) 2) ""))