summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-11 01:34:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:22 +0100
commit058766ec7aee9373346c28497af1875da82aa991 (patch)
treefbdbf8768cf024474b9a65eab6be89de79b879d2
parentae1ec6b0e4ecb09ab5cb02822b9516d5c9aaac6a (diff)
gnu: corefreq: Stop using %OUTPUTS.
* gnu/packages/linux.scm (corefreq)[arguments]: Use Gexps to remove use of %OUTPUTS.
-rw-r--r--gnu/packages/linux.scm76
1 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1e39d3d078..c752df7996 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1237,44 +1237,44 @@ and should be used with caution, especially on untested models.")
(build-system linux-module-build-system)
(outputs (list "out" "linux-module"))
(arguments
- `(#:imported-modules ((guix build gnu-build-system)
- ,@%linux-module-build-system-modules)
- #:modules ((guix build linux-module-build-system)
- ((guix build gnu-build-system) #:prefix gnu:)
- (guix build utils))
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- "OPTIM_LVL=3"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:tests? #f ; no test suite
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'untangle-module-targets
- ;; Having to build everything in one pass would complicate the
- ;; definition. Let each build system handle what it's good at.
- (lambda _
- (substitute* "Makefile"
- ((".*MAKE.*KERNELDIR.*") ""))))
- (add-after 'build 'gnu:build
- (assoc-ref gnu:%standard-phases 'build))
- (add-after 'install 'gnu:install
- (assoc-ref gnu:%standard-phases 'install))
- (add-after 'install 'separate-module
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Adding INSTALL_MOD_PATH= to #:make-flags would still create an
- ;; empty <out>/lib/modules directory, so just do it all by hand.
- (let* ((out (assoc-ref outputs "out"))
- (module (assoc-ref outputs "linux-module")))
- (mkdir-p (string-append module "/lib"))
- (rename-file (string-append out "/lib/modules")
- (string-append module "/lib/modules")))))
- (add-after 'install 'install-README
- ;; There is no proper documentation. Provide something.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/"
- ,name "-" ,version)))
- (install-file "README.md" doc)))))))
+ (list #:imported-modules `((guix build gnu-build-system)
+ ,@%linux-module-build-system-modules)
+ #:modules `((guix build linux-module-build-system)
+ ((guix build gnu-build-system) #:prefix gnu:)
+ (guix build utils))
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ "OPTIM_LVL=3"
+ (string-append "PREFIX=" #$output))
+ #:tests? #f ; no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'untangle-module-targets
+ ;; Having to build everything in one pass would complicate the
+ ;; definition. Let each build system handle what it's good at.
+ (lambda _
+ (substitute* "Makefile"
+ ((".*MAKE.*KERNELDIR.*") ""))))
+ (add-after 'build 'gnu:build
+ (assoc-ref gnu:%standard-phases 'build))
+ (add-after 'install 'gnu:install
+ (assoc-ref gnu:%standard-phases 'install))
+ (add-after 'install 'separate-module
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Adding INSTALL_MOD_PATH= to #:make-flags would still create an
+ ;; empty <out>/lib/modules directory, so just do it all by hand.
+ (let* ((out (assoc-ref outputs "out"))
+ (module (assoc-ref outputs "linux-module")))
+ (mkdir-p (string-append module "/lib"))
+ (rename-file (string-append out "/lib/modules")
+ (string-append module "/lib/modules")))))
+ (add-after 'install 'install-README
+ ;; There is no proper documentation. Provide something.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/"
+ #$name "-" #$version)))
+ (install-file "README.md" doc)))))))
(home-page "https://github.com/cyring/CoreFreq")
(synopsis
"Measure performance data & tweak low-level settings on x86-64 CPUs")