summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-06 14:25:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:23 +0100
commit13f769c165c06b97472f61902d491c8910e86f8b (patch)
treef62f9b6957b5cd5d6328113f5e73ea03ba4f5c7b
parentc4b786fb339112c2e9ccb1c5ebc6fba8ec582c11 (diff)
gnu: festival: Support ALSA output.
* gnu/packages/speech.scm (festival)[arguments]: Add "LINUXAUDIO=alsa" to #:make-flags. [inputs]: Add alsa-lib.
-rw-r--r--gnu/packages/speech.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 9e687fb632..e0927ca97c 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -342,7 +342,8 @@ be used by the sighted.")
"/bin/rm")
(string-append "ECHO_N="
(assoc-ref %build-inputs "coreutils")
- "/bin/printf \"%s\""))
+ "/bin/printf \"%s\"")
+ "LINUXAUDIO=alsa")
#:parallel-build? #f ; not supported
#:modules ((guix build gnu-build-system)
(guix build utils)
@@ -505,7 +506,8 @@ be used by the sighted.")
(add-before 'configure 'bootstrap
(lambda _ (invoke "autoreconf" "-vif"))))))
(inputs
- (list ncurses))
+ (list alsa-lib
+ ncurses))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)