summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-14 19:04:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-14 19:04:09 +0100
commit4558a98389fb00ea06e330d42524b7a0f144df6a (patch)
tree4337ddea77a7fdb40b344edeaabed2c3dd719e89
parentb1d7112f8e36bcc2597d1f8af0510c853bea2d2c (diff)
gnu: emacs-ag: Use new style.
* gnu/packages/emacs-xyz.scm (emacs-ag)[arguments]<#:phases>: Remove trailing [propagated-inputs]: Remove labels.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3e38b3cabf..0ed7845724 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2534,15 +2534,15 @@ links.")
(package
(name "emacs-ag")
(version "0.48")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/ag.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1p918y24vcn2pdliaymd210xp9fvhd4a1srqbv2lfiqrh59yjidx"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/ag.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p918y24vcn2pdliaymd210xp9fvhd4a1srqbv2lfiqrh59yjidx"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -2555,15 +2555,13 @@ links.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(info (string-append out "/share/info")))
- (install-file "docs/_build/texinfo/agel.info" info)
- #t))))))
+ (install-file "docs/_build/texinfo/agel.info" info)))))))
(native-inputs
(list python-sphinx texinfo))
(propagated-inputs
- `(("dash" ,emacs-dash)
- ("s" ,emacs-s)
- ;; We need to use 'ag' as the executable on remote systems.
- ("the-silver-searcher" ,the-silver-searcher)))
+ (list emacs-dash
+ emacs-s
+ the-silver-searcher)) ;'ag' executable
(home-page "https://github.com/Wilfred/ag.el")
(synopsis "Front-end for ag (the-silver-searcher) for Emacs")
(description "This package provides the ability to use the silver