summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-13 23:23:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-14 15:34:44 +0100
commit76ab15a7c958752b0e5de12580e88e1927891c6d (patch)
tree8fa691acd3d2abe602ec816bf37a9227ceaa3627
parentd6fa2381da42892fdbd0a02e03e3e2c0602e9a21 (diff)
gnu: tensorflow: Do not unpack directory.
* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Copy Eigen source code instead of trying to unpack it.
-rw-r--r--gnu/packages/machine-learning.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3bcc6d3df4..58f7c7c013 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1899,8 +1899,7 @@ set(eigen_INCLUDE_DIRS ${CMAKE_CURRENT_BINARY_DIR}/external/eigen_archive "
(invoke "tar" "xf" (assoc-ref inputs "protobuf:src")
"-C" "protobuf-src" "--strip-components=1")
(mkdir-p "eigen-src")
- (invoke "tar" "xf" (assoc-ref inputs "eigen:src")
- "-C" "eigen-src" "--strip-components=1")
+ (copy-recursively (assoc-ref inputs "eigen:src") "eigen-src")
(substitute* "tensorflow/contrib/cmake/tf_python.cmake"
;; Take protobuf source files from our source package.