summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-14 20:10:48 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-15 00:41:07 +0100
commit8da6dfb0bbb00c330bfa053741f5a58b66219463 (patch)
treed16b107216909d2a02b451d5657edccd4ef481e9
parenta284e56de44717f1ad4aa884a1777441324738f2 (diff)
gnu: libgit2: Allow cross-compilation.
With commit 8394619baceb118df92e355377fd543bb1aa501a, the label for 'pkg-config' when cross-compiling changed to "TRIPLET-pkg-config", thereby breaking the 'assoc-ref' call. This commit fixes it by avoiding referring to the label. * gnu/packages/version-control.scm (libgit2)[arguments]: Adjust "-DPKG_CONFIG_EXECUTABLE=" option.
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d7ea61e5fb..bc999bf3dc 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -811,8 +811,10 @@ to GitHub contributions calendar.")
,@(if (%current-target-system)
`((string-append
"-DPKG_CONFIG_EXECUTABLE="
- (assoc-ref %build-inputs "pkg-config")
- "/bin/" ,(%current-target-system) "-pkg-config"))
+ (search-input-file
+ %build-inputs
+ (string-append "/bin/" ,(%current-target-system)
+ "-pkg-config"))))
'()))
#:phases
(modify-phases %standard-phases