summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 00:57:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:23 +0100
commita0fd9a35321438cba2f380c339d1c11f4e4750d7 (patch)
tree217db243e5b75cdd3d1984b320a65e4d35870a18
parent5ee8589c867030bed4405b8a9724be5ca40eb29e (diff)
gnu: i7z: Fix building with GCC >= 10.
* gnu/packages/hardware.scm (i7z)[source]: Add patch. * gnu/packages/patches/i7z-gcc-10.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hardware.scm3
-rw-r--r--gnu/packages/patches/i7z-gcc-10.patch23
3 files changed, 27 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 56ae2c3c76..a138e574d0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1255,6 +1255,7 @@ dist_patch_DATA = \
%D%/packages/patches/hurd-cross.patch \
%D%/packages/patches/hurd-xattr.patch \
%D%/packages/patches/hydra-disable-darcs-test.patch \
+ %D%/packages/patches/i7z-gcc-10.patch \
%D%/packages/patches/icecat-makeicecat.patch \
%D%/packages/patches/icecat-avoid-bundled-libraries.patch \
%D%/packages/patches/icecat-use-older-reveal-hidden-html.patch \
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 7f6e858ee0..ddd0f5acc1 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -25,6 +25,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages hardware)
+ #:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
@@ -330,6 +331,8 @@ whether the hardware works with a fully free operating system or not.")
(file-name (git-file-name name version))
(sha256
(base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+ (patches
+ (search-patches "i7z-gcc-10.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/i7z-gcc-10.patch b/gnu/packages/patches/i7z-gcc-10.patch
new file mode 100644
index 0000000000..407e17a995
--- /dev/null
+++ b/gnu/packages/patches/i7z-gcc-10.patch
@@ -0,0 +1,23 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sat, 11 Dec 2021 19:22:49 +0100
+Subject: [PATCH] gnu: i7z: Build with GCC 10.
+
+Patch from Debian, modified to apply to our i7z sources in src/.
+
+Author: Andreas Beckmann <anbe@debian.org>
+Description: fix FTBFS with gcc-10
+ gcc-10 defaults to -fno-common
+ see https://gcc.gnu.org/gcc-10/porting_to.html
+Bug-Debian: https://bugs.debian.org/957351
+
+--- a/src/i7z_Dual_Socket.c
++++ b/src/i7z_Dual_Socket.c
+@@ -37,7 +37,7 @@ float Read_Voltage_CPU(int cpu_num);
+ extern struct program_options prog_options;
+ FILE *fp_log_file;
+
+-struct timespec global_ts;
++extern struct timespec global_ts;
+ extern FILE *fp_log_file_freq_1, *fp_log_file_freq_2;
+
+ extern char* CPU_FREQUENCY_LOGGING_FILE_single;