summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-14 19:20:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-14 19:20:14 +0100
commitb1cfd7a40b52b7f5bef58785b8567e8f43f257ac (patch)
tree3146232a52c9578eb0bc81ea97d7a53934a38d27
parentd1b435366c5dd41a6d6555d4ab50754b8da25dab (diff)
gnu: emacs-direnv: Use new style.
* gnu/packages/emacs-xyz.scm (emacs-direnv)[arguments]: Use SEARCH-INPUT. [propagated-inputs]: Remove labels.
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d2781339b5..7f509ce7a7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2927,16 +2927,13 @@ overlay below or above the point. Corfu can be considered the minimalistic
(modify-phases %standard-phases
(add-after 'unpack 'patch-in-direnv
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((direnv-path (assoc-ref inputs "direnv"))
- (direnv-bin (string-append
- "\"" direnv-path "/bin/direnv\"")))
+ (let ((direnv (search-input-file inputs "/bin/direnv")))
(substitute* "direnv.el"
- (("\"direnv\"") direnv-bin))))))))
+ (("\"direnv\"") (string-append "\"" direnv "\"")))))))))
(inputs
(list direnv))
(propagated-inputs
- `(("dash" ,emacs-dash)
- ("with-editor" ,emacs-with-editor)))
+ (list emacs-dash emacs-with-editor))
(home-page "https://github.com/wbolster/emacs-direnv")
(synopsis "Direnv integration for Emacs")
(description