summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 00:59:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:23 +0100
commitc4b786fb339112c2e9ccb1c5ebc6fba8ec582c11 (patch)
tree285e0ba3f64142adbb440be6983d8e1c7e14b0d6
parentcf879dc0b6fcbf9c49515209f8c0d92cebc98d84 (diff)
gnu: igt-gpu-tools: Include man pages.
* gnu/packages/admin.scm (igt-gpu-tools)[arguments]: Add a new 'find-rst2man.py phase. (native-inputs): Add python-docutils.
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 63d0760a2d..42f06447cc 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3550,6 +3550,10 @@ buffers.")
`(#:tests? #f ; many of the tests try to load kernel modules
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'find-rst2man.py
+ (lambda _
+ (substitute* "man/meson.build"
+ (("'rst2man'") "'rst2man.py'"))))
(add-after 'unpack 'fix-meson.build
;; Fix ‘ERROR: Function does not take positional arguments.’
(lambda _
@@ -3566,7 +3570,7 @@ buffers.")
libunwind
procps))
(native-inputs
- (list bison flex pkg-config))
+ (list bison flex pkg-config python-docutils))
(home-page "https://gitlab.freedesktop.org/drm/igt-gpu-tools")
(synopsis "Tools for development and testing of the Intel DRM driver")
(description "IGT GPU Tools is a collection of tools for development and