summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2021-12-14 21:21:41 -0500
committerLeo Famulari <leo@famulari.name>2021-12-15 00:40:14 -0500
commitc7795eccaf432beec7366fa901b4bb6fc24cfead (patch)
tree9bcf69fb257a4d33ad8233a10bbf5207f514c629
parent9f955a1cfd8f3b8fe066034878131f0e2518740b (diff)
gnu: libpfm4: Fix build error.
------ For some reason, the build recently failed with: pfmlib_perf_event_pmu.c:349:36: error: ?%s? directive output may be truncated writing up to 255 bytes into a region of size between 0 and 4095 [-Werror=format-truncation=] 349 | snprintf(d2path, MAXPATHLEN, "%s/%s", debugfs_mnt, d1->d_name); | ^~ pfmlib_perf_event_pmu.c:349:3: note: ?snprintf? output between 2 and 4352 bytes into a destination of size 4096 349 | snprintf(d2path, MAXPATHLEN, "%s/%s", debugfs_mnt, d1->d_name); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ pfmlib_perf_event_pmu.c:399:58: error: ?%s? directive output may be truncated writing up to 255 bytes into a region of size between 0 and 4095 [-Werror=format-truncation=] 399 | snprintf(idpath, MAXPATHLEN, "%s/%s/id", d2path, d2->d_name); | ^~ pfmlib_perf_event_pmu.c:399:25: note: ?snprintf? output between 5 and 4355 bytes into a destination of size 4096 399 | snprintf(idpath, MAXPATHLEN, "%s/%s/id", d2path, d2->d_name); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors ------ * gnu/packages/linux.scm (libpfm4)[arguments]: Add `-Wno-format-truncation` to CFLAGS in custom 'build' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/linux.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c752df7996..a1c9408e89 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7632,6 +7632,7 @@ high-speed networking devices.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(setenv "CC" "gcc")
+ (setenv "CFLAGS" "-Wno-format-truncation")
(invoke "make")
#t)))
(replace 'install