summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-13 02:15:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-14 19:35:23 +0100
commitcf879dc0b6fcbf9c49515209f8c0d92cebc98d84 (patch)
treeccd77aa667ee824668b72dcc61972e21c2593f7f
parenta0fd9a35321438cba2f380c339d1c11f4e4750d7 (diff)
gnu: igt-gpu-tools: Fix build with newer Mesons.
* gnu/packages/admin.scm (igt-gpu-tools)[arguments]: Add a new 'fix-meson.build phase.
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index de2f67f238..63d0760a2d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3534,6 +3534,7 @@ buffers.")
(define-public igt-gpu-tools
(package
(name "igt-gpu-tools")
+ ;; You should very likely remove the 'fix-meson.build phase when upgrading.
(version "1.26")
(source
(origin
@@ -3546,7 +3547,15 @@ buffers.")
(base32 "0m124pqv7zna25jnvk566c4kk628jr0w8mgnp8mr5xqz9cprgczm"))))
(build-system meson-build-system)
(arguments
- `(#:tests? #f)) ; many of the tests try to load kernel modules
+ `(#:tests? #f ; many of the tests try to load kernel modules
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-meson.build
+ ;; Fix ‘ERROR: Function does not take positional arguments.’
+ (lambda _
+ (substitute* "lib/meson.build"
+ (("f\\.underscorify\\(f\\)")
+ "f.underscorify()")))))))
(inputs
(list cairo
elfutils ; libdw