summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-13 12:02:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-14 15:34:40 +0100
commitd6fa2381da42892fdbd0a02e03e3e2c0602e9a21 (patch)
tree29e350227a197ac1053d6e379b0aaf1f40cb53ed
parent46fc72b2bfee2a30a3c3f3320e7d84b4b2fd646e (diff)
gnu: python2-entrypoints: Add missing input.
* gnu/packages/python-xyz.scm (python2-entrypoints)[propagated-inputs]: Add python2-configparser. (python-entrypoints)[properties]: Add python2-variant.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 270d665251..8d3b582841 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11814,10 +11814,15 @@ objects with some common interface. The most common examples are
@code{console_scripts} entry points, which define shell commands by
identifying a Python function to run. The @code{entrypoints} module contains
functions to find and load entry points.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-entrypoints))))))
(define-public python2-entrypoints
- (package-with-python2 python-entrypoints))
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-entrypoints)))
+ (propagated-inputs
+ (list python2-configparser))))
(define-public python-epc
(package