summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-15 00:37:02 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-15 00:41:08 +0100
commite874c730eaa369e42cff3b2c2e3599d33a7aceff (patch)
treef07fbce771ef1c84e6d367d1d0b6c32a55739a3c
parent3bfdf1c3821367539598bfba0640965291c3f360 (diff)
gnu: ableton-link: Update to 3.0.3.
* gnu/packages/audio.scm (ableton-link): Update to 3.0.3. [arguments]: In phases, change source directory to "../source". Remove trailing #t.
-rw-r--r--gnu/packages/audio.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2181b8e907..520843347a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5200,7 +5200,7 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
(define-public ableton-link
(package
(name "ableton-link")
- (version "3.0.2")
+ (version "3.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5209,7 +5209,7 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
(file-name (git-file-name name version))
(sha256
(base32
- "0262vm0v7hmqjhqx5xikh529p3c065p1yld6ymaiz74yq1dnnjir"))
+ "1wplqj11ww64gmw2kzlxpvfs3v04m2036f7k5ndm34zcv12b91fa"))
(modules '((guix build utils)))
(patches
(search-patches "ableton-link-system-libraries-debian.patch"))
@@ -5221,8 +5221,7 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
(("root_dir,") "root_dir, os.pardir,"))
;; Unbundle dependencies.
(delete-file-recursively "third_party")
- (delete-file-recursively "modules")
- #t))))
+ (delete-file-recursively "modules")))))
(build-system cmake-build-system)
(native-inputs
(list catch-framework
@@ -5247,16 +5246,12 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
(let* ((python (search-input-file inputs "/bin/python3"))
- (run-tests (string-append "../ableton-link-"
- ,version
- "-checkout/ci/run-tests.py")))
+ (run-tests "../source/ci/run-tests.py"))
(invoke python run-tests "--target" "LinkCoreTest")
(invoke python run-tests "--target" "LinkDiscoveryTest"))))
(add-before 'install 'patch-cmake
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((source (string-append "../ableton-link-"
- ,version
- "-checkout/")))
+ (let* ((source "../source/"))
(substitute* (string-append source
"cmake_include/AsioStandaloneConfig.cmake")
(((string-append "\\$\\{CMAKE_CURRENT_LIST_DIR\\}/\\.\\./"
@@ -5267,14 +5262,13 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
(("\\$\\{CMAKE_CURRENT_LIST_DIR\\}/include")
"${CMAKE_CURRENT_LIST_DIR}/../../../include")
(("\\$\\{CMAKE_CURRENT_LIST_DIR\\}/include/ableton/Link\\.hpp")
- "${CMAKE_CURRENT_LIST_DIR}/../../../include/ableton/Link.hpp"))
- #t)))
+ "${CMAKE_CURRENT_LIST_DIR}/../../../include/ableton/Link.hpp")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(lib-cmake (string-append out "/lib/cmake/ableton-link"))
- (source (string-append "../ableton-link-" ,version "-checkout")))
+ (source "../source"))
(for-each (lambda (test-file)
(delete-file test-file))
'("bin/LinkDiscoveryTest" "bin/LinkCoreTest"))
@@ -5285,8 +5279,7 @@ Rate} 3600x2250 bit/s vocoder used in various radio systems.")
lib-cmake)
(install-file (string-append source
"/cmake_include/AsioStandaloneConfig.cmake")
- (string-append lib-cmake "/cmake_include"))
- #t))))))
+ (string-append lib-cmake "/cmake_include"))))))))
(home-page "https://github.com/Ableton/link")
(synopsis "Synchronize musical beat, tempo, and phase across multiple applications")
(description