summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-14 11:31:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-14 13:43:12 +0300
commit4a2798e0672cb610313b8ea833b802adfe905c92 (patch)
treebe2125d2ea4032b6207ec173b359449e4642b278
parent76e8566c1b3c4876d649e712a5c8c473fd48d134 (diff)
gnu: freeimage: Use 'modify-phases' syntax.
* gnu/packages/image.scm (freeimage)[arguments]: Use 'modify-phases' syntax.
-rw-r--r--gnu/packages/image.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 27060d5ff1..7455bb8889 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -585,15 +585,15 @@ supplies a generic doubly-linked list and some string functions.")
"freeimage-CVE-2016-5684.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-delete
- 'configure
- (alist-cons-before
- 'build 'patch-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile.gnu"
- (("/usr") (assoc-ref outputs "out"))
- (("-o root -g root") "")))
- %standard-phases))
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile.gnu"
+ (("/usr") (assoc-ref outputs "out"))
+ (("-o root -g root") ""))
+ #t)))
#:make-flags '("CC=gcc")
#:tests? #f)) ; no check target
(native-inputs