summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-07 21:50:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 17:22:40 +0200
commitb02f7a21d1f143951170236aef3ef1e5e8a464c9 (patch)
treedffd2cc7fd35b28782f5e44ef78a25b9bd977493
parentde585a7e644fdcb6ea05abde23f900d4242fcb48 (diff)
gnu: python-zope-testing: Strip byte-code and backup-files from source.
* gnu/package/python.scm (python-zope-testing, python2-zope-testing)[source]: Add snippet to strip byte-code and backup-files.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index eca60bc251..ec56c8593f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6644,7 +6644,13 @@ that have uses outside of the Zope framework.")
"/zope.testing/zope.testing-" version ".tar.gz"))
(sha256
(base32
- "1yvglxhzvhl45mndvn9gskx2ph30zz1bz7rrlyfs62fv2pvih90s"))))
+ "1yvglxhzvhl45mndvn9gskx2ph30zz1bz7rrlyfs62fv2pvih90s"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-compiled .pyc files backup files from source.
+ (for-each delete-file (find-files "." "(\\.pyc|~)$"))
+ #t))))
(build-system python-build-system)
(native-inputs
`(("python-zope-exceptions" ,python-zope-exceptions)))