summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-10-11 10:54:28 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-10-11 12:24:57 -0400
commitb25f060fbde97bd4f9863c8521396639d53b8831 (patch)
tree8f4ea4974076bbcb9e0da4b6576d44a9eae933ba
parent65375f74bce923a5ddbba4819237055d0656a1cd (diff)
gnu: redis: Update to 3.2.4.
* gnu/packages/databases.scm (redis): Update to 3.2.4. [arguments]: Add LDFLAGS to #:make-flags to work around missing linker flag.
-rw-r--r--gnu/packages/databases.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index eb8e7d7bde..902b3f32fa 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -952,14 +952,14 @@ similar to BerkeleyDB, LevelDB, etc.")
(define-public redis
(package
(name "redis")
- (version "3.2.3")
+ (version "3.2.4")
(source (origin
(method url-fetch)
(uri (string-append "http://download.redis.io/releases/redis-"
version".tar.gz"))
(sha256
(base32
- "05az2g3gna5lkhh6x1a5m6yardbiig1l4ysggldlk5if8ww9qkk7"))))
+ "1wb9jd692a0y52bkkxr6815kk4g039mirjdrvqx24265lv2l5l1a"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; tests related to master/slave and replication fail
@@ -967,6 +967,7 @@ similar to BerkeleyDB, LevelDB, etc.")
(delete 'configure))
#:make-flags `("CC=gcc"
"MALLOC=libc"
+ "LDFLAGS=-ldl"
,(string-append "PREFIX="
(assoc-ref %outputs "out")))))
(synopsis "Key-value cache and store")