summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-13 10:56:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-16 12:55:43 +0200
commitb7afd01893ef2f08049810bd63784e915a8a2f9a (patch)
tree570ac1611594bb2bd86edb970338fe1ca46302e7
parent569f60164920a36e6597fe25e9373f97f89e8860 (diff)
gnu: Add python-whoosh.
* gnu/packages/python.scm (python-whoosh, python2-whoosh): New variables.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6207896abc..69c7d360eb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8823,6 +8823,36 @@ library.")
(native-inputs `(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs responses))))))
+(define-public python-whoosh
+ (package
+ (name "python-whoosh")
+ (version "2.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Whoosh" version))
+ (sha256
+ (base32
+ "10qsqdjpbc85fykc1vgcs8xwbgn4l2l52c8d83xf1q59pwyn79bw"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pytest" ,python-pytest)))
+ (home-page "http://bitbucket.org/mchaput/whoosh")
+ (synopsis "Full text indexing, search, and spell checking library")
+ (description
+ "Whoosh is a fast, pure-Python full text indexing, search, and spell
+checking library.")
+ (license license:bsd-2)))
+
+(define-public python2-whoosh
+ (let ((whoosh (package-with-python2 (strip-python2-variant python-whoosh))))
+ (package (inherit whoosh)
+ (propagated-inputs
+ `(("python2-backport-ssl-match-hostname"
+ ,python2-backport-ssl-match-hostname)
+ ,@(package-propagated-inputs whoosh))))))
+
(define-public python-pathlib
(package
(name "python-pathlib")