summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-21 22:45:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-26 03:25:23 +0200
commitcd9e7dc7ff32e04accd1910cd2bc060bf6c23857 (patch)
tree97f806345f4a8a1e3f612a27a3eb55f19d5feb97
parente8163773746bad6e20072d52b577d5209ba47cdc (diff)
gnu: Add r-rbgl.
* gnu/packages/bioinformatics.scm (r-rbgl): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 27646ff34c..0456cc61c7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5199,6 +5199,27 @@ distribution.")
databases. Packages produced are intended to be used with AnnotationDbi.")
(license license:artistic2.0)))
+(define-public r-rbgl
+ (package
+ (name "r-rbgl")
+ (version "1.48.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RBGL" version))
+ (sha256
+ (base32
+ "1k82zcbyfx3p9hc8r0hwq73krbhakjan8fgbfr6w8z2crfkv3zmz"))))
+ (properties `((upstream-name . "RBGL")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-graph" ,r-graph)))
+ (home-page "http://www.bioconductor.org/packages/RBGL")
+ (synopsis "Interface to the Boost graph library")
+ (description
+ "This package provides a fairly extensive and comprehensive interface to
+the graph algorithms contained in the Boost library.")
+ (license license:artistic2.0)))
+
(define-public vsearch
(package
(name "vsearch")