summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-10-15 15:49:13 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 18:13:58 -0400
commitfcb9b9340fd9557441bf42ca9b93a7651a5c94f9 (patch)
treebae7d5e6a5344084f4abd9bdc693121baacc0e8a
parent7f8fec0fa40951de33822f86c31c32e3f3c5513e (diff)
gnu: dbus-1.10.12: Fix search paths.
Add the patches from dbus's source field back into its replacement. This ensures that the grafted dbus package can find its services on GuixSD. This is a follow-up to commit 34f9582aad557cd816bb3215fb4d7da7d1c5229a. * gnu/packages/glib.scm (dbus-1.10.12)[source]: Inherit from dbus. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/glib.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e549dd7377..802c809c26 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -139,7 +139,7 @@ shared NFS home directories.")
(source
(let ((version "1.10.12"))
(origin
- (method url-fetch)
+ (inherit (package-source dbus))
(uri (string-append
"https://dbus.freedesktop.org/releases/dbus/dbus-"
version ".tar.gz"))