summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-07 23:51:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 23:52:44 +0100
commit20662a30201d638594a8b9d1878cd3cce467cda7 (patch)
treeb37dab30248d97352f9454c58b6f4dd691dc56e3
parent8f37f538374c10e404d44ed036fb197a46fcd6f0 (diff)
gnu: r-ggmap: Update to 3.0.0.
* gnu/packages/cran.scm (r-ggmap): Update to 3.0.0. [propagated-inputs]: Add r-bitops, r-dplyr, r-glue, r-httr, r-magrittr, r-purrr, r-stringr, r-tibble, and r-tidyr; remove r-geosphere, r-mapproj, r-proto, and r-reshape2.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 324753322e..5bd5c60d49 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -995,28 +995,33 @@ applications. That is, compute distances and related measures for angular
(define-public r-ggmap
(package
(name "r-ggmap")
- (version "2.6.2")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggmap" version))
(sha256
(base32
- "144x6ycb2c3fvy5c68ww53m6gzi6kfvas7cpbn071z08n4xgb72f"))))
+ "13dmzl6z62pzjiffilarkji46vy0sacxa8a7mhrhc3biq3ylzhln"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-digest" ,r-digest)
- ("r-geosphere" ,r-geosphere)
+ `(("r-bitops" ,r-bitops)
+ ("r-digest" ,r-digest)
+ ("r-dplyr" ,r-dplyr)
("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-httr" ,r-httr)
("r-jpeg" ,r-jpeg)
- ("r-mapproj" ,r-mapproj)
+ ("r-magrittr" ,r-magrittr)
("r-plyr" ,r-plyr)
("r-png" ,r-png)
- ("r-proto" ,r-proto)
- ("r-reshape2" ,r-reshape2)
+ ("r-purrr" ,r-purrr)
("r-rgooglemaps" ,r-rgooglemaps)
("r-rjson" ,r-rjson)
- ("r-scales" ,r-scales)))
+ ("r-scales" ,r-scales)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
(home-page "https://github.com/dkahle/ggmap")
(synopsis "Spatial visualization with ggplot2")
(description "This package provides a collection of functions to visualize