summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-09 12:30:24 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-09 12:30:24 +0100
commit2b613a1a5d4d41b0b5d1f6ea7254585be0c209fa (patch)
treee733367d1bc3c4e2006e02a96fb35ebc2a546b27
parent7d4cab7473cc9a9c4c831a6c83fa172bd7ab6f10 (diff)
gnu: hyperledger-fabric: Fix description, set supported system and parallel build.
* gnu/packages/hyperledger.scm (hyperledger-fabric)[description]: Rephrase into something less marketing-ish. [arguments]: Build with multiple jobs. [supported-systems]: Support x86_64-linux only.
-rw-r--r--gnu/packages/hyperledger.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/hyperledger.scm b/gnu/packages/hyperledger.scm
index 5f8b782818..b25a3c48e7 100644
--- a/gnu/packages/hyperledger.scm
+++ b/gnu/packages/hyperledger.scm
@@ -65,7 +65,9 @@
(replace 'build
(lambda _
;; Only linux-amd64 and linux-ppc64le seem to be supported at the moment.
- (invoke "make" "-C" "src/github.com/hyperledger/fabric"
+ (invoke "make"
+ "-j" (number->string (parallel-job-count))
+ "-C" "src/github.com/hyperledger/fabric"
"release/linux-amd64")))
(add-after 'install 'install-commands
(lambda* (#:key outputs #:allow-other-keys)
@@ -82,8 +84,10 @@
(copy-recursively "sampleconfig"
(string-append out "/etc/hyperledger/fabric"))))
#t)))))
+ (supported-systems '("x86_64-linux"))
(synopsis "Platform for distributed ledger solutions")
- (description "A platform for distributed ledger solutions, underpinned by
-a modular architecture delivering high degrees of confidentiality, resiliency,
-flexibility and scalability.")
+ (description "Hyperledger Fabric is a platform for distributed ledger
+solutions, underpinned by a modular architecture focusing on confidentiality
+and resiliency. It is designed to support pluggable implementations of
+different components.")
(license asl2.0)))