summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 13:28:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 13:28:45 +0100
commit4fc9b5b1dd6024a3e4962626ee6c7196bc298ebf (patch)
tree1cef0ea04e1f3b613d136a63dab322e8a0c83950
parent1fe9a36173335b559c695357bc8d884f1d4b144a (diff)
gnu: Add genrich.
* gnu/packages/bioinformatics.scm (genrich): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3093d7ead6..092c49d8cb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13113,6 +13113,38 @@ descriptive settings file. The result is a set of comprehensive, interactive
HTML reports with interesting findings about your samples.")
(license license:gpl3+)))
+(define-public genrich
+ (package
+ (name "genrich")
+ (version "0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jsh58/Genrich.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0x0q6z0208n3cxzqjla4rgjqpyqgwpmz27852lcvzkzaigymq4zp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "Genrich" (string-append (assoc-ref outputs "out") "/bin"))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/jsh58/Genrich")
+ (synopsis "Detecting sites of genomic enrichment")
+ (description "Genrich is a peak-caller for genomic enrichment
+assays (e.g. ChIP-seq, ATAC-seq). It analyzes alignment files generated
+following the assay and produces a file detailing peaks of significant
+enrichment.")
+ (license license:expat)))
+
(define-public mantis
(let ((commit "4ffd171632c2cb0056a86d709dfd2bf21bc69b84")
(revision "1"))