summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-08 22:59:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-08 23:00:07 +0100
commit8b6acb1f20638de5b90c284baacc6058f7ffaa62 (patch)
tree80d2223e0208245f3367a7a67dbf6d136a3fad5f
parentf87dcb4d75d9bef74ae7f97962435402ad2078a7 (diff)
gnu: blast+: Update to 2.7.1.
* gnu/packages/bioinformatics.scm (blast+): Update to 2.7.1. [inputs]: Add lmdb. [source]: Remove obsolete patch. * gnu/package/patches/blast+-fix-makefile.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm6
-rw-r--r--gnu/packages/patches/blast+-fix-makefile.patch15
3 files changed, 3 insertions, 19 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2971f3f87b..aeeedf45fc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -670,7 +670,6 @@ dist_patch_DATA = \
%D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/biber-fix-encoding-write.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
- %D%/packages/patches/blast+-fix-makefile.patch \
%D%/packages/patches/boost-fix-icu-build.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ced948a5d1..26fcc3a41a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1092,7 +1092,7 @@ package provides command line tools using the Bio++ library.")
(define-public blast+
(package
(name "blast+")
- (version "2.6.0")
+ (version "2.7.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1100,8 +1100,7 @@ package provides command line tools using the Bio++ library.")
version "/ncbi-blast-" version "+-src.tar.gz"))
(sha256
(base32
- "15n937pw5aqmyfjb6l387d18grqbb96l63d5xj4l7yyh0zbf2405"))
- (patches (search-patches "blast+-fix-makefile.patch"))
+ "1jlq0afxxgczpp35k6mxh8mn4jzq7vqcnaixk166sfj10wq8v9qh"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1209,6 +1208,7 @@ package provides command line tools using the Bio++ library.")
"include")) ; 33 MB
(inputs
`(("bzip2" ,bzip2)
+ ("lmdb" ,lmdb)
("zlib" ,zlib)
("pcre" ,pcre)
("perl" ,perl)
diff --git a/gnu/packages/patches/blast+-fix-makefile.patch b/gnu/packages/patches/blast+-fix-makefile.patch
deleted file mode 100644
index bfa46a7e51..0000000000
--- a/gnu/packages/patches/blast+-fix-makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Without this patch, the 'make install' attempts to 'install' a directory, which causes an error.
-
-diff --git a/c++/src/build-system/Makefile.in.top b/c++/src/build-system/Makefile.in.top
-index 1abe44f..d6000b3 100644
---- a/c++/src/build-system/Makefile.in.top
-+++ b/c++/src/build-system/Makefile.in.top
-@@ -51,7 +51,7 @@ install-toolkit:
- done
- cd $(includedir0) && find * -name CVS -prune -o -print |\
- cpio -pd $(pincludedir)
-- $(INSTALL) -m 644 $(incdir)/* $(pincludedir)
-+ cp -R $(incdir)/* $(pincludedir)
- ## set up appropriate build and status directories somewhere under $(libdir)?
-
- install-gbench: