summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 22:01:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 22:01:36 +0100
commitb7f3ea9532c0bf764228b3b7ecbd66d579a2517f (patch)
tree432eb97171c2e6cc2e0d1f2ede9d5bdb7dac0815
parentf620311a39a9a7dd8bd2637251e448824423a17f (diff)
gnu: python-fake-factory: Fix tests.
* gnu/packages/python.scm (python-fake-factory, python2-fake-factory)[arguments]: Replace 'check' phase with custom command.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index de11cd558d..d6ea07de34 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10484,6 +10484,12 @@ parsing UK postcodes.")
(base32
"0vs0dkmg0dlaxf8w6q2i3k0i03gmp56ablldv7ci9x3nbadkn71g"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "-m" "unittest" "-v" "faker.tests")))))))
(native-inputs
`(;; For testing
("python-email-validator" ,python-email-validator)