summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-08 21:49:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-08 21:49:25 +0100
commitf87dcb4d75d9bef74ae7f97962435402ad2078a7 (patch)
treea11993f123f150ae180d89cfe490e153359b9d24
parentcafd4d387b213f1f50c9c2a9af0f45a1fe41516f (diff)
gnu: Add texlive-latex-pdfx.
* gnu/packages/tex.scm (texlive-latex-pdfx): New variable.
-rw-r--r--gnu/packages/tex.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d2ded49efc..a0eeb23950 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6482,3 +6482,55 @@ digital material to enhance the workflow in publication. The essence is that
the metadata is stored in an XML file, and this XML stream is then embedded in
the file to which it applies.")
(license license:gpl3+)))
+
+(define-public texlive-latex-pdfx
+ (package
+ (name "texlive-latex-pdfx")
+ (version (number->string %texlive-revision))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "pdfx"))
+ (sha256
+ (base32
+ "0ikxg8yzq78hy5b9x13d4nah46d0yvmwlqmdri06pygbx116dcac"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/pdfx"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-encoding
+ (lambda _
+ (substitute* "pdfx.dtx"
+ ((" .+umaczy") "umaczy"))
+ #t))
+ (add-before 'install 'install-tex-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/tex/latex/pdfx")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref inputs "texlive-tex-pdfx") target)
+ ;; Install the generated version in the "install" phase.
+ (delete-file (string-append target "/pdfx.sty"))
+ #t))))))
+ (propagated-inputs
+ `(("texlive-generic-pdftex" ,texlive-generic-pdftex)))
+ (native-inputs
+ `(("texlive-tex-pdfx"
+ ,(origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/pdfx"))
+ (revision %texlive-revision)))
+ (file-name (string-append "texlive-tex-latex-pdfx-" version "-checkout"))
+ (sha256
+ (base32
+ "14j1zsvqc59ims3sk34v6km8db6cimks28y5fcxcr5mi2ykvj4vf"))))))
+ (home-page "https://www.ctan.org/pkg/pdfx")
+ (synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
+ (description
+ "This package helps LaTeX users to create PDF/X, PFD/A and other
+standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
+ (license license:lppl1.2+)))