summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-01 22:22:45 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-02 15:04:52 +0200
commit69e7da457dd6a8bc3092729a1393575a58b61117 (patch)
treee9a505e86e9bb2467258b3bc633ae2fd7e9a4888
parent7341dee7f92a7361869dff175b37dc557be2430a (diff)
gnu: epiphany: Fix playing of media.
* gnu/packages/gnome.scm (epiphany) [arguments]<#:phases>['wrap-epiphany]: New phase. [inputs]: Add gstreamer, gst-plugins-bad, gst-plugins-base, gst-plugins-good and gst-plugins-ugly. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c291579809..00b36bbf45 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7705,7 +7705,13 @@ a secret password store, an adblocker, and a modern UI.")
(rename-file
(string-append out "/share/help")
(string-append help "/share/help"))
- #t))))))
+ #t)))
+ (add-after 'move-help 'wrap-epiphany
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" = (,(getenv "GST_PLUGIN_SYSTEM_PATH")))))
+ #t)))))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
("glib:bin" ,glib "bin")
@@ -7725,6 +7731,11 @@ a secret password store, an adblocker, and a modern UI.")
("glib-networking" ,glib-networking)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gst-plugins-ugly" ,gst-plugins-ugly)
("gtk+" ,gtk+)
("json-glib" ,json-glib)
("iso-codes" ,iso-codes)