summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-26 12:56:43 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-29 09:12:19 +0200
commitf01822fe46a18cfe68a780794683b65032d0eda7 (patch)
treee082d993d24efb87d5955c0517801fb262a90515
parentbb6b9065f90cdc401d8de943077678239a122a61 (diff)
gnu: gedit: Remove unncessary wrapping and fix loading of svg files.
* gnu/packages/gnome.scm (gedit) [inputs]: Add gdk-pixbuf+svg. [arguments]<#:phases>['wrap-gedit]: Remove phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1b95eee4c4..fbc757aae2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8333,16 +8333,7 @@ spidermonkey javascript engine and the GObject introspection framework.")
(rename-file
(string-append out "/share/help")
(string-append help "/share/help"))
- #t)))
- (add-after 'move-help 'wrap-gedit
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (gtksourceview (assoc-ref inputs "gtksourceview")))
- (wrap-program (string-append out "/bin/gedit")
- ;; For language-specs.
- `("XDG_DATA_DIRS" ":" prefix (,(string-append gtksourceview
- "/share")))))
- #t)))))
+ #t))))))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
("docbook-xml-4.1.2" ,docbook-xml-4.1.2)
@@ -8369,6 +8360,7 @@ spidermonkey javascript engine and the GObject introspection framework.")
(inputs
`(("adwaita-icon-theme" ,adwaita-icon-theme)
("appstream-util" ,appstream-glib)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("glib" ,glib)
("gnome-desktop" ,gnome-desktop)
("gspell" ,gspell)