summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-23 13:51:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-23 14:10:02 +0100
commit032a26d50b9d6a452b9521bacbc54b30158ed87b (patch)
tree9fbe657245564cc748cf52533a02545d2f3f9315
parent78e93c267725cd3bb986d72aa1c03d6da75bb551 (diff)
gnu: Add emacs-svg-tag-mode.
* gnu/packages/emacs-xyz.scm (emacs-svg-tag-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a548c83290..b89b818778 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15951,6 +15951,28 @@ your Emacs.")
within Emacs.")
(license license:gpl3+))))
+(define-public emacs-svg-tag-mode
+ (let ((commit "87489d28450559078aa15b4a435143a297508e48")
+ (revision "1"))
+ (package
+ (name "emacs-svg-tag-mode")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rougier/svg-tag-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gyhmv60dx0zxx4bmhzsd7q5vfnkpfwlj6539bn272fwcr7zncp8"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rougier/svg-tag-mode")
+ (synopsis "Replace keywords with SVG tags")
+ (description "This package provides a minor mode that replaces keywords
+or expressions with SVG rounded box labels that are fully customizable.")
+ (license license:gpl3+))))
+
(define-public emacs-sourcemap
(package
(name "emacs-sourcemap")