summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-12-27 15:27:36 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-27 17:12:06 +0100
commit32568f5b2438f859f54ec22372d08edc0962a329 (patch)
tree4ba20754866c8347a68e1efae8b135b2fb90d8cc
parenta016a451c41486d8f8277742d47157cc2597d5bc (diff)
gnu: Add Guile-zstd.
* gnu/packages/guile.scm (guile-zstd): New variable.
-rw-r--r--gnu/packages/guile.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 11694e06f9..9413258384 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -848,4 +848,32 @@ pure Scheme by using Guile's foreign function interface.")
(home-page "https://notabug.org/guile-lzlib/guile-lzlib")
(license license:gpl3+)))
+(define-public guile-zstd
+ (package
+ (name "guile-zstd")
+ (version "0.1.1")
+ (home-page "https://notabug.org/guile-zstd/guile-zstd")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c8l7829b5yx8wdc0mrhzjfwb6h9hb7cd8dfxcr71a7vlsi86310"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("guile" ,guile-3.0)))
+ (inputs
+ `(("zstd" ,zstd "lib")
+ ("guile" ,guile-3.0)))
+ (synopsis "GNU Guile bindings to the zstd compression library")
+ (description
+ "This package provides a GNU Guile interface to the zstd (``zstandard'')
+compression library.")
+ (license license:gpl3+)))
+
;;; guile.scm ends here