summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-11-29 14:49:29 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2020-12-28 01:00:06 +0100
commit40afc2f4e2850bd442d4f022d200184d683c3fd8 (patch)
tree796504c93f7d1491e32dbcb5f61a0bd909fcfbcd
parent67a608403eb75df3eedd57b966ff70771c99ee9e (diff)
gnu: Add ruby-rugged.
* gnu/packages/ruby.scm (ruby-rugged): New variable. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1befecfa12..5a89288166 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11716,3 +11717,30 @@ which snapshots to consider and what files to include.")
defined in @file{.travis.yml} on your local machine, using @code{rvm},
@code{rbenv}, or @code{chruby} to test different versions of Ruby.")
(license license:expat)))
+
+(define-public ruby-rugged
+ (package
+ (name "ruby-rugged")
+ (version "1.1.0")
+ (home-page "https://www.rubydoc.info/gems/rugged")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rugged" version))
+ (sha256
+ (base32 "04aq913plcxjw71l5r62qgz3bx3466p0wvgyfqahg5n3nybmcwqy"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:gem-flags (list "--" "--use-system-libraries")))
+ (inputs
+ `(("libgit2" ,libgit2)))
+ (native-inputs
+ `(("ruby-minitest" ,ruby-minitest)
+ ("ruby-pry" ,ruby-pry)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Ruby bindings to the libgit2 linkable C Git library")
+ (description "Rugged is a library for accessing libgit2 in Ruby. It gives
+you the speed and portability of libgit2 with the beauty of the Ruby
+language.")
+ (license license:expat)))