summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-17 15:24:18 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-26 22:29:59 +0200
commit77a48a4c5de26db652d8eb4e1c414806e12fecc1 (patch)
tree28d5f78c7940ba5fee946cc438c805e37bdbf003
parent7bcd1f90d3860bdbb9bf4751191d328c156edfd4 (diff)
gnu: miredo: Fix to use iproute2 from the store.
* gnu/packages/networking.scm (miredo): [inputs]: Add iproute. [arguments]: New phase 'patch-iproute2 that patches sources to use iproute2 from the store. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ff1de3a0cb..479f5329f5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -702,6 +702,13 @@ or, more generally, MAC addresses of the same category of hardware.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-iproute2
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((iproute (assoc-ref inputs "iproute"))
+ (ip (string-append iproute "/sbin/ip")))
+ (substitute* "misc/client-hook.iproute"
+ (("/sbin/ip") ip))
+ #t)))
;; The checkconf test in src/ requires network access.
(add-before
'check 'disable-checkconf-test
@@ -709,6 +716,8 @@ or, more generally, MAC addresses of the same category of hardware.")
(substitute* "src/Makefile"
(("^TESTS = .*") "TESTS = \n"))
#t)))))
+ (inputs
+ `(("iproute" ,iproute)))
(home-page "https://www.remlab.net/miredo/")
(synopsis "Teredo IPv6 tunneling software")
(description