summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-10 22:37:08 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-10 22:37:08 +0100
commit99662b8dbf420d0112f83b7daddcecfb1bcb9bad (patch)
tree4da01ede0efb634b3804968d3bb26c1f9ebe0e81
parentc2e65167212f15093f672ebc49f3f7d4a51fcd2b (diff)
gnu: glibc: Upgrade to 2.19.
* gnu/packages/base.scm (glibc): Upgrade to 2.19. Remove 'glibc-make-4.0.patch'. * gnu/packages/patches/glibc-make-4.0.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/base.scm8
-rw-r--r--gnu/packages/patches/glibc-make-4.0.patch12
3 files changed, 3 insertions, 18 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 244012037d..d993571a1a 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -253,7 +253,6 @@ dist_patch_DATA = \
gnu/packages/patches/glib-tests-prlimit.patch \
gnu/packages/patches/glibc-bootstrap-system.patch \
gnu/packages/patches/glibc-ldd-x86_64.patch \
- gnu/packages/patches/glibc-make-4.0.patch \
gnu/packages/patches/gobject-introspection-cc.patch \
gnu/packages/patches/grub-gets-undeclared.patch \
gnu/packages/patches/gstreamer-0.10-bison3.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d6f75be238..f0fe5caaa3 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -364,14 +364,14 @@ library for working with executable and object formats is also included.")
(define-public glibc
(package
(name "glibc")
- (version "2.18")
+ (version "2.19")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "18spla703zav8dq9fw7rbzkyv9qfisxb26p7amg1x3wjh7iy3d1c"))
+ "18m2dssd6ja5arxmdxinc90xvpqcsnqjfwmjl2as07j0i3srff9d"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -381,9 +381,7 @@ library for working with executable and object formats is also included.")
"use_ldconfig=no")))
(modules '((guix build utils)))
(imported-modules modules)
- (patches (map search-patch
- '("glibc-ldd-x86_64.patch"
- "glibc-make-4.0.patch")))))
+ (patches (list (search-patch "glibc-ldd-x86_64.patch")))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc
diff --git a/gnu/packages/patches/glibc-make-4.0.patch b/gnu/packages/patches/glibc-make-4.0.patch
deleted file mode 100644
index d83de1d33d..0000000000
--- a/gnu/packages/patches/glibc-make-4.0.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Allow libc to be compiled with GNU Make 4.0.
-
---- glibc-2.18/configure 2013-08-11 00:52:55.000000000 +0200
-+++ glibc-2.18/configure 2013-10-16 16:53:09.000000000 +0200
-@@ -4772,7 +4772,7 @@ $as_echo_n "checking version of $MAKE...
- ac_prog_version=`$MAKE --version 2>&1 | sed -n 's/^.*GNU Make[^0-9]*\([0-9][0-9.]*\).*$/\1/p'`
- case $ac_prog_version in
- '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
-- 3.79* | 3.[89]*)
-+ 3.79* | 3.[89]* | 4.*)
- ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
- *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;