summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-12-23 21:57:14 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-12-23 21:58:40 +0300
commit9bc00fb9573a1881be53ea29205483d5c901d98e (patch)
tree43826b65fc732a7d74ddc2cd2823ac30c8068e73
parent5540159f3e34ac8f6b3ab31f773f6e286028f309 (diff)
Revert "gnu: gita: Update to 0.11.9."
This reverts commit 5540159f3e34ac8f6b3ab31f773f6e286028f309 which updates gita to v0.11.9 tag, which doesn't contain freeze and clone sub-commands.
-rw-r--r--gnu/packages/version-control.scm96
1 files changed, 49 insertions, 47 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a445f40385..d20cf7e655 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2903,52 +2903,54 @@ defects faster.")
(license license:asl2.0)))
(define-public gita
- (package
- (name "gita")
- (version "0.11.9")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nosarthur/gita")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15hfr7zk41kqsnszlgddfhz717mw4bxqwsn0nvjwg53x1hnfxv7p"))))
- (build-system python-build-system)
- (native-inputs
- `(("git" ,git) ;for tests
- ("python-pytest" ,python-pytest)))
- (propagated-inputs
- `(("python-pyyaml" ,python-pyyaml)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "tests/test_main.py"
- (("'gita\\\\n'") "'source\\n'")
- (("'gita'") "'source'"))
- (invoke (string-append (assoc-ref inputs "git") "/bin/git")
- "init")
- (add-installed-pythonpath inputs outputs)
- (invoke (string-append (assoc-ref inputs "python-pytest")
- "/bin/pytest")
- "-vv" "tests")))
- (add-after 'install 'install-shell-completions
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bash-completion (string-append out "/etc/bash_completion.d"))
- (zsh-completion (string-append out "/etc/zsh/site-functions")))
- (mkdir-p bash-completion)
- (copy-file ".gita-completion.bash"
- (string-append bash-completion "/gita"))
- (mkdir-p zsh-completion)
- (copy-file ".gita-completion.zsh"
- (string-append zsh-completion "/_gita"))))))))
- (home-page "https://github.com/nosarthur/gita")
- (synopsis "Command-line tool to manage multiple Git repos")
- (description "This package provides a command-line tool to manage
+ (let ((commit "62eb3d69874f75bdd6f95743e57315bc59890f70")
+ (revision "1"))
+ (package
+ (name "gita")
+ (version (git-version "0.10.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nosarthur/gita")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jn5wnmjbdrrgz9fif7s81pv3g92q0wjcqy5qxl77kjy7iv0kpfp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("git" ,git) ;for tests
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-pyyaml" ,python-pyyaml)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "tests/test_main.py"
+ (("'gita\\\\n'") "'source\\n'")
+ (("'gita'") "'source'"))
+ (invoke (string-append (assoc-ref inputs "git") "/bin/git")
+ "init")
+ (add-installed-pythonpath inputs outputs)
+ (invoke (string-append (assoc-ref inputs "python-pytest")
+ "/bin/pytest")
+ "-vv" "tests")))
+ (add-after 'install 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash-completion (string-append out "/etc/bash_completion.d"))
+ (zsh-completion (string-append out "/etc/zsh/site-functions")))
+ (mkdir-p bash-completion)
+ (copy-file ".gita-completion.bash"
+ (string-append bash-completion "/gita"))
+ (mkdir-p zsh-completion)
+ (copy-file ".gita-completion.zsh"
+ (string-append zsh-completion "/_gita"))))))))
+ (home-page "https://github.com/nosarthur/gita")
+ (synopsis "Command-line tool to manage multiple Git repos")
+ (description "This package provides a command-line tool to manage
multiple Git repos.
This tool does two things:
@@ -2959,4 +2961,4 @@ commit message side by side
@end itemize
If several repos are related, it helps to see their status together.")
- (license license:expat)))
+ (license license:expat))))