summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2020-12-27 19:50:40 -0800
committerChris Marusich <cmmarusich@gmail.com>2020-12-27 20:03:57 -0800
commitfdb90e9ee8a578c88ef3a33067e8a532e43ae7b8 (patch)
treea98f006fa89276f89b6fdfc6b87d8c1f700fa9af
parentf9e1baa8933ea2ed385d0272dbfbe4e22f192bde (diff)
gnu: libffi: On powerpc64le, patch using --force.
As explained in bug 45252, this is the right way to invoke it. * gnu/packages/libffi.scm (arguments): Change the invocation of the "patch" tool in the case where the %current-target-system or %current-system begins with "powerpc64le", so that we invoke it using --force instead of --batch.
-rw-r--r--gnu/packages/libffi.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 66239e0363..375a792ebf 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -76,7 +76,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(let ((patch (assoc-ref inputs
"powerpc64le-patch")))
- (invoke "patch" "--batch" "-p1"
+ (invoke "patch" "--force" "-p1"
"-i" patch))))))
'())))
(inputs