summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2023-04-11 18:09:54 +1000
committerRicardo Wurmus <rekado@elephly.net>2024-01-11 14:39:56 +0100
commit1f2ddc966bddeaac84db5bac712d5f11bddbb03e (patch)
tree096ba8860731d9573408635c79f68aa5003c5fcf
parent4f7fe2767c65ecf12ad17262885ae25658f09ac8 (diff)
gnu: lilv: Update to 0.24.20.
* gnu/packages/audio.scm (lilv): Update to 0.24.20. [build-system]: Use meson. [arguments]: Remove.ldflag hack not needed with meson. [home-page]: Append ".html". Change-Id: Ia4edfe436d8bb45c937d77c385c3e472df335ca8
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2a5f438817..02df5230da 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3041,24 +3041,19 @@ frequencies. This data is then formatted to MIDI and written to disk.")
(define-public lilv
(package
(name "lilv")
- (version "0.24.12")
+ (version "0.24.20")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/lilv-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "0qchfsyrsrp2pdpd59025kllycr04ddpzd03ha1iz70ci687g8r6"))))
- (build-system waf-build-system)
+ "1g7f29i0jajswyg67k7hdnmyqk32fmmxw6xppf9fm1mjp2wq5c2g"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))))
(add-after 'unpack 'full-store-path-to-shared-library
(lambda* (#:key outputs #:allow-other-keys)
(with-directory-excursion "bindings/python"
@@ -3070,7 +3065,7 @@ frequencies. This data is then formatted to MIDI and written to disk.")
(list lv2 serd sord sratom))
(native-inputs
(list python pkg-config))
- (home-page "https://drobilla.net/software/lilv")
+ (home-page "https://drobilla.net/software/lilv.html")
(synopsis "Library to simplify use of LV2 plugins in applications")
(description
"Lilv is a C library to make the use of LV2 plugins as simple as possible