summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-11 10:38:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-11 14:39:56 +0100
commit9e24e467ac08e3614743b8bcdc1d16a017e95ac5 (patch)
tree211daf23df0e5008bcb2f7ef8cd0c5144cfd88f1
parent6d015dbdd9bb8ebf5349cc222a05c4dac986914c (diff)
gnu: python-sanic-testing: Update to 23.12.0.
* gnu/packages/python-web.scm (python-sanic-testing): Update to 23.12.0. [build-system]: Use pyproject-build-system. [arguments]: Remove 'loosen-requirements phase. [propagated-inputs]: Remove python-websockets. Change-Id: Ie1958070959692ae678ffeefda9ee8bafa86a5e6
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3a4dfc9edd..e724f94348 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7132,29 +7132,19 @@ the @code{BasicRouter}.")
(define-public python-sanic-testing
(package
(name "python-sanic-testing")
- (version "22.3.0")
+ (version "23.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sanic-testing" version))
(sha256
- (base32 "1vkgi9d3xyik507j4jy9s74mkl81hgx3c2d5y3aa1av9h6wjjivp"))))
- (build-system python-build-system)
+ (base32 "0gqkzv90sbj9rw7yfly9c58lq9dq30g5hhcgjl3ihzjb66vm571b"))))
+ (build-system pyproject-build-system)
(arguments
;; PyPi sources does not contain tests, recursive dependency on
;; python-sanic.
- (list #:tests? #f
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'loosen-requirements
- (lambda _
- ;; Don't place an upper boundary on httpx version.
- ;; https://github.com/sanic-org/sanic-testing/pull/39
- (substitute* "setup.py"
- (("httpx>=0\\.18,<0\\.23")
- "httpx>=0.18")))))))
- (propagated-inputs (list python-httpx python-sanic-bootstrap
- python-websockets))
+ (list #:tests? #f))
+ (propagated-inputs (list python-httpx python-sanic-bootstrap))
(home-page "https://github.com/sanic-org/sanic-testing/")
(synopsis "Test clients for Sanic")
(description "Internal package for @code{python-sanic}, which is