summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-11 11:08:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-11 14:39:56 +0100
commite780b794ca7a94e0a2f84b9d54227e00a33045a7 (patch)
tree2fbe3d33567d873e7a1ce27774c446571e030e47
parent9e24e467ac08e3614743b8bcdc1d16a017e95ac5 (diff)
gnu: python-pytest-sanic: Relax requirement on websockets.
* gnu/packages/python-check.scm (python-pytest-sanic)[arguments]: Use plain list; add 'relax-requirements phase. [description]: Use complete sentence. Change-Id: I3c21380b4aa208da8a92270b6748b620a4a2dcc0
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f02ca10298..37cabf4cff 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -2140,20 +2140,29 @@ help in debugging failures and optimizing the scheduler to improve speed.")
(method url-fetch)
(uri (pypi-uri "pytest-sanic" version))
(sha256
- (base32
- "0shq1bqnydj0l3ipb73j1qh5kqcjvzkps30zk8grq3dwmh3wmnkr"))))
+ (base32
+ "0shq1bqnydj0l3ipb73j1qh5kqcjvzkps30zk8grq3dwmh3wmnkr"))))
+ ;; We don't use pyproject-build-system because that would require
+ ;; poetry.masonry.
(build-system python-build-system)
(arguments
;; Tests depend on python-sanic.
- `(#:tests? #f))
+ (list
+ #:tests? #f
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("websockets.*<11.0")
+ "websockets<12.0")))))))
(propagated-inputs
- (list python-httpx python-async-generator python-pytest
- python-websockets))
- (home-page
- "https://github.com/yunstanford/pytest-sanic")
+ (list python-httpx python-async-generator python-pytest
+ python-websockets))
+ (home-page "https://github.com/yunstanford/pytest-sanic")
(synopsis "Pytest plugin for Sanic")
- (description "A pytest plugin for Sanic. It helps you to test your
-code asynchronously.")
+ (description "This package provides a pytest plugin for Sanic. It helps
+you to test your code asynchronously.")
(license license:expat)))
(define-public python-allpairspy