summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 01:37:14 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 01:37:14 +0200
commit358970fed6cf6ec3bb475e7385db269754095051 (patch)
tree93eb626269eb2164fa167e5edbbd3f5e141a3cba
parent56a9e299c216eb68c949e0b406d17ddea176e073 (diff)
gnu: libltdl: Explicity declare the _FILE_OFFSET_BITS we want.
* gnu/packages/autotools.scm (libltdl)[arguments]<#:phases>[ensure-file-offset-bits-64]: Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/autotools.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index febaabcf99..38840e9f7c 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -487,6 +487,16 @@ complexity of working with shared libraries across platforms.")
(arguments
'(#:configure-flags '("--enable-ltdl-install") ;really install it
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'ensure-file-offset-bits-64
+ (lambda _
+ (setenv "CFLAGS" "-D_FILE_OFFSET_BITS=64")
+ (substitute* "libltdl/libltdl/lt__dirent.h"
+ (("#define LT__DIRENT_H 1") "#define LT__DIRENT_H 1
+#if !defined(_FILE_OFFSET_BITS) || _FILE_OFFSET_BITS != 64
+#error \"libltdl was compiled with _FILE_OFFSET_BITS == 64, so you have to be, too (since it exports readdir)\"
+#endif
+"))
+ #t))
(add-before 'configure 'change-directory
(lambda _ (chdir "libltdl") #t)))))