summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 12:45:35 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 15:17:03 +0200
commit3c34647a6b4834f71db1c27fd0aeb963d3267888 (patch)
treefc18e2790d84227de65e97c9c03d640e773155a5
parent358970fed6cf6ec3bb475e7385db269754095051 (diff)
gnu: rhash: Explicity declare the _FILE_OFFSET_BITS we want.
* gnu/packages/crypto.scm (rhash)[arguments]<#:make-flags>: Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 028c140185..a10dd62e8b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -845,8 +845,13 @@ BLAKE.")
"/bin/" ,target "-gcc"))
'())))
#:make-flags
- ;; The binaries in /bin need some help finding librhash.so.0.
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ (list ;; This package uses a configure script that is not from GNU
+ ;; autotools; it doesn't handle the environment variable
+ ;; CFLAGS (or for that matter the configure option).
+ ;; Therefore, directly pass it to make.
+ "CFLAGS=-D_FILE_OFFSET_BITS=64"
+ ;; The binaries in /bin need some help finding librhash.so.0.
+ (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:test-target "test" ; ‘make check’ just checks the sources
#:phases
(modify-phases %standard-phases